What’s Vulnerable › Vulnerabilities
CVE-2024-10976: PostgreSQL row security below e.g. subqueries disregards user ID changes
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-1250
Description
Incomplete tracking in PostgreSQL of tables with row security allows a reused query to view or change different rows from those intended. CVE-2023-2455 and CVE-2016-2193 fixed most interaction between row security and user ID changes. They missed cases where a subquery, WITH query, security invoker view, or SQL-language function references a table with a row-level security policy. This has the same consequences as the two earlier CVEs. That is to say, it leads to potentially incorrect policies being applied in cases where role-specific policies are used and a given query is planned under one role and then executed under other roles. This scenario can happen under security definer functions or when a common user and query is planned initially and then re-used across multiple SET ROLEs. Applying an incorrect policy may permit a user to complete otherwise-forbidden reads and modifications. This affects only databases that have used CREATE POLICY to define a row security policy. An attacker must tailor an attack to a particular application's pattern of query plan reuse, user ID changes, and role-specific row security policies. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.
Affected products
- PostgreSQL: from 12.0 before 12.21; from 13.0 before 13.17; from 14.0 before 14.14; from 15.0 before 15.9; from 16.0 before 16.5; from 17.0 before 17.1 — fixed in 12.21, 13.17, 14.14, 15.9, 16.5, 17.1
How to fix
Upgrade to a fixed version: PostgreSQL 12.21, 13.17, 14.14, 15.9. Check the vendor advisory for mitigations.
References
- https://www.postgresql.org/support/security/CVE-2024-10976/
- https://lists.debian.org/debian-lts-announce/2024/11/msg00011.html
- https://security.netapp.com/advisory/ntap-20250509-0010/
Get alerted when CVE-2024-10976 or the next vulnerability affects your stack