What’s Vulnerable › Vulnerabilities
CVE-2024-10977: PostgreSQL libpq retains an error message from man-in-the-middle
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-348
Description
Client use of server error message in PostgreSQL allows a server not trusted under current SSL or GSS settings to furnish arbitrary non-NUL bytes to the libpq application. For example, a man-in-the-middle attacker could send a long error message that a human or screen-scraper user of psql mistakes for valid query results. This is probably not a concern for clients where the user interface unambiguously indicates the boundary between one error message and other text. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.
Affected products
- PostgreSQL: from 12.0 before 12.21; from 13.0 before 13.17; from 14.0 before 14.14; from 15.0 before 15.9; from 16.0 before 16.5; 17.0, 17.0-beta1, 17.0-beta2, 17.0-beta3, 17.0-rc1 — fixed in 12.21, 13.17, 14.14, 15.9, 16.5
How to fix
Upgrade to a fixed version: PostgreSQL 12.21, 13.17, 14.14, 15.9. Check the vendor advisory for mitigations.
References
- https://www.postgresql.org/support/security/CVE-2024-10977/
- https://lists.debian.org/debian-lts-announce/2024/11/msg00011.html
Get alerted when CVE-2024-10977 or the next vulnerability affects your stack