What’s Vulnerable › Vulnerabilities
CVE-2024-10978: PostgreSQL SET ROLE, SET SESSION AUTHORIZATION reset to wrong user ID
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-266
Description
Incorrect privilege assignment in PostgreSQL allows a less-privileged application user to view or change different rows from those intended. An attack requires the application to use SET ROLE, SET SESSION AUTHORIZATION, or an equivalent feature. The problem arises when an application query uses parameters from the attacker or conveys query results to the attacker. If that query reacts to current_setting('role') or the current user ID, it may modify or return data as though the session had not used SET ROLE or SET SESSION AUTHORIZATION. The attacker does not control which incorrect user ID applies. Query text from less-privileged sources is not a concern here, because SET ROLE and SET SESSION AUTHORIZATION are not sandboxes for unvetted queries. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.
Affected products
- Debian Linux: 11.0
- PostgreSQL: from 12.0 before 12.21; from 13.0 before 13.17; from 14.0 before 14.14; from 15.0 before 15.9; from 16.0 before 16.5; 17.0, 17.0-beta1, 17.0-beta2, 17.0-beta3, 17.0-rc1 — fixed in 12.21, 13.17, 14.14, 15.9, 16.5
How to fix
Upgrade to a fixed version: PostgreSQL 12.21, 13.17, 14.14, 15.9. Check the vendor advisory for mitigations.
References
- https://www.postgresql.org/support/security/CVE-2024-10978/
- https://lists.debian.org/debian-lts-announce/2024/11/msg00011.html
- https://lists.debian.org/debian-lts-announce/2024/11/msg00018.html
- https://www.postgresql.org/message-id/173171334532.1547978.1518068370217143844%40wrigleys.postgresql.org
Get alerted when CVE-2024-10978 or the next vulnerability affects your stack