What’s Vulnerable › Vulnerabilities
CVE-2024-10980: Element Pack Elementor Addons < 5.10.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid, Carousel and Remote Arrows) WordPress plugin before 5.10.3 does not validate and escape some of its Cookie Consent block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- bdthemes Element Pack – Widgets, Templates & Addons for Elementor: before 5.10.3 — fixed in 5.10.3
How to fix
Upgrade to a fixed version: bdthemes Element Pack – Widgets, Templates & Addons for Elementor 5.10.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10980 or the next vulnerability affects your stack