What’s Vulnerable › Vulnerabilities
CVE-2024-11002: InPost Gallery <= 2.1.4.2 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via inpost_gallery_get_shortcode_template
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-94
Description
The The InPost Gallery plugin for WordPress is vulnerable to arbitrary shortcode execution via the inpost_gallery_get_shortcode_template AJAX action in all versions up to, and including, 2.1.4.2. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes.
Affected products
- RealMag777 InPost Gallery: before 2.1.4.3 — fixed in 2.1.4.3
How to fix
Upgrade to a fixed version: RealMag777 InPost Gallery 2.1.4.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/inpost-gallery/trunk/index.php#L323
- https://plugins.trac.wordpress.org/changeset/3192113/
- https://wordpress.org/plugins/inpost-gallery/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5fbb2dcf-38b8-4ef1-bfea-bf5872cc7e37?source=cve
Get alerted when CVE-2024-11002 or the next vulnerability affects your stack