What’s Vulnerable › Vulnerabilities
CVE-2024-11005
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-78
Description
Command injection in Ivanti Connect Secure before version 22.7R2.1 (Not Applicable to 9.1Rx) and Ivanti Policy Secure before version 22.7R1.1 (Not Applicable to 9.1Rx) allows a remote authenticated attacker with admin privileges to achieve remote code execution.
Affected products
- Ivanti Connect Secure (Pulse Secure): before 9.1; from 9.1 (excl.) before 22.7; 22.7, 22.7-r1, 22.7-r1.1, 22.7-r1.2, 22.7-r1.3, 22.7-r1.4 (+2) — fixed in 22.7, 9.1
- Ivanti Policy Secure: before 9.1; from 9.1 (excl.) before 22.7; 22.7-r1 — fixed in 22.7, 9.1
How to fix
Upgrade to a fixed version: Ivanti Connect Secure (Pulse Secure) 22.7, 9.1; Ivanti Policy Secure 22.7, 9.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11005 or the next vulnerability affects your stack