What’s Vulnerable › Vulnerabilities
CVE-2024-11024: AppPresser – Mobile App Framework <= 4.4.6 - Unauthenticated Privilege Escalation via Password Reset
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-230
Description
The AppPresser – Mobile App Framework plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 4.4.6. This is due to the plugin not properly validating a user's password reset code prior to updating their password. This makes it possible for unauthenticated attackers, with knowledge of a user's email address, to reset the user's password and gain access to their account.
Affected products
- scottopolis AppPresser – Mobile App Framework: before 4.4.7 — fixed in 4.4.7
How to fix
Upgrade to a fixed version: scottopolis AppPresser – Mobile App Framework 4.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3192531/apppresser
- https://www.wordfence.com/threat-intel/vulnerabilities/id/43cb0399-4add-43d5-863c-30e11803bd90?source=cve
Get alerted when CVE-2024-11024 or the next vulnerability affects your stack