What’s Vulnerable › Vulnerabilities
CVE-2024-11038: WPB Popup for Contact Form 7 – Showing The Contact Form 7 Popup on Button Click – CF7 Popup <= 1.7.5 - Unauthenticated Arbitrary Shortcode Execution via wpb_pcf_fire_contact_form
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-06-17
- Weakness: CWE-94
Description
The The WPB Popup for Contact Form 7 – Showing The Contact Form 7 Popup on Button Click – CF7 Popup plugin for WordPress is vulnerable to arbitrary shortcode execution via wpb_pcf_fire_contact_form AJAX action in all versions up to, and including, 1.7.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Affected products
- wpbean WPB Popup for Contact Form 7 – Showing Contact Form 7 Popup on Button Click: before 1.7.6 — fixed in 1.7.6
How to fix
Upgrade to a fixed version: wpbean WPB Popup for Contact Form 7 – Showing Contact Form 7 Popup on Button Click 1.7.6. Check the vendor advisory for mitigations.
References
- https://gist.github.com/wpbean/1a5abfea883621b4e150eab1362a420f
- https://plugins.trac.wordpress.org/browser/wpb-popup-for-contact-form-7/tags/1.7.4/includes/class.ajax.php#L34
- https://plugins.trac.wordpress.org/changeset/3188864/
- https://wordpress.org/plugins/wpb-popup-for-contact-form-7/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a7faa800-3b29-4b79-8b94-1e7985acb50d?source=cve
Get alerted when CVE-2024-11038 or the next vulnerability affects your stack