What’s Vulnerable › Vulnerabilities
CVE-2024-11039: Deserialization of Untrusted Data in binary-husky/gpt_academic
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-502
Description
A pickle deserialization vulnerability exists in the Latex English error correction plug-in function of binary-husky/gpt_academic versions up to and including 3.83. This vulnerability allows attackers to achieve remote command execution by deserializing untrusted data. The issue arises from the inclusion of numpy in the deserialization whitelist, which can be exploited by constructing a malicious compressed package containing a merge_result.pkl file and a merge_proofread_en.tex file. The vulnerability is fixed in commit 91f5e6b.
Affected products
- binary-husky/gpt_academic: before 3.91 — fixed in 3.91
How to fix
Upgrade to a fixed version: binary-husky/gpt_academic 3.91. Check the vendor advisory for mitigations.
References
- https://github.com/binary-husky/gpt_academic/commit/91f5e6b8f754beb47b02f7c1893804c1c9543ccb
- https://huntr.com/bounties/f233a365-522c-44f6-876f-db492fb58ad5
Get alerted when CVE-2024-11039 or the next vulnerability affects your stack