What’s Vulnerable › Vulnerabilities
CVE-2024-11042: Arbitrary File Delete in invoke-ai/invokeai
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-73
Description
In invoke-ai/invokeai version v5.0.2, the web API `POST /api/v1/images/delete` is vulnerable to Arbitrary File Deletion. This vulnerability allows unauthorized attackers to delete arbitrary files on the server, potentially including critical or sensitive system files such as SSH keys, SQLite databases, and configuration files. This can impact the integrity and availability of applications relying on these files.
Affected products
- invoke-ai/invokeai: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: invoke-ai/invokeai 5.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/invoke-ai/invokeai/commit/5440c037674882b2ab7acd59087e9bb04b49657a
- https://huntr.com/bounties/635535a7-c804-4789-ac3a-48d951263987
Get alerted when CVE-2024-11042 or the next vulnerability affects your stack