What’s Vulnerable › Vulnerabilities
CVE-2024-1106: Shariff Wrapper < 4.6.10 - Admin+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Shariff Wrapper WordPress plugin before 4.6.10 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- 3uu Shariff Wrapper: before 4.6.10 — fixed in 4.6.10
How to fix
Upgrade to a fixed version: 3uu Shariff Wrapper 4.6.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0672f8af-33e2-459c-ac8a-7351247a8a26/
- https://wpscan.com/vulnerability/0672f8af-33e2-459c-ac8a-7351247a8a26/
Get alerted when CVE-2024-1106 or the next vulnerability affects your stack