What’s Vulnerable › Vulnerabilities
CVE-2024-11069: WordPress GDPR <= 2.0.2 - Missing Authorization to Unauthenticated Arbitrary User Deletion
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-06-17
- Weakness: CWE-862
Description
The WordPress GDPR plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'WordPress_GDPR_Data_Delete::check_action' function in all versions up to, and including, 2.0.2. This makes it possible for unauthenticated attackers to delete arbitrary users.
Affected products
- welaunch WordPress GDPR: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: welaunch WordPress GDPR 2.0.3. Check the vendor advisory for mitigations.
References
- https://www.welaunch.io/en/product/wordpress-gdpr/#changelog
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a089026a-5da9-467c-a1e4-622bb74363e2?source=cve
Get alerted when CVE-2024-11069 or the next vulnerability affects your stack