What’s Vulnerable › Vulnerabilities
CVE-2024-1108: Plugin Groups <= 2.0.6 - Missing Authorization to Unauthenticated Denial of Service
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-21 · updated 2026-06-17
- Weakness: CWE-862
Description
The Plugin Groups plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the admin_init() function in all versions up to, and including, 2.0.6. This makes it possible for unauthenticated attackers to change the settings of the plugin, which can also cause a denial of service due to a misconfiguration.
Affected products
- desertsnowman Plugin Groups: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: desertsnowman Plugin Groups 2.0.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3036754/plugin-groups/trunk/classes/class-plugin-groups.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8298f1fb-3165-40e3-9192-805a07c14cae?source=cve
- https://plugins.trac.wordpress.org/changeset/3036754/plugin-groups/trunk/classes/class-plugin-groups.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8298f1fb-3165-40e3-9192-805a07c14cae?source=cve
Get alerted when CVE-2024-1108 or the next vulnerability affects your stack