What’s Vulnerable › Vulnerabilities
CVE-2024-11089: Anonymous Restricted Content <= 1.6.5 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-21 · updated 2026-06-17
- Weakness: CWE-200
Description
The Anonymous Restricted Content plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.6.5 via the WordPress core search feature. This makes it possible for unauthenticated attackers to extract sensitive data from posts that have been restricted to logged-in users.
Affected products
- cayenne Anonymous Restricted Content: before 1.6.6 — fixed in 1.6.6
How to fix
Upgrade to a fixed version: cayenne Anonymous Restricted Content 1.6.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3191193/anonymous-restricted-content
- https://www.wordfence.com/threat-intel/vulnerabilities/id/95a01f44-2356-4ea4-b48e-80e3c6114efa?source=cve
Get alerted when CVE-2024-11089 or the next vulnerability affects your stack