What’s Vulnerable › Vulnerabilities
CVE-2024-11129: Generation of Error Message Containing Sensitive Information in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-10 · updated 2026-06-17
- Weakness: CWE-209
Description
An issue has been discovered in GitLab EE affecting all versions from 17.1 before 17.8.7, 17.9 before 17.9.6, and 17.10 before 17.10.4. This allows attackers to perform targeted searches with sensitive keywords to get the count of issues containing the searched term."
Affected products
- GitLab: from 17.1.0 before 17.8.6; from 17.1.0 before 17.8.7; from 17.9.0 before 17.9.6; from 17.10.0 before 17.10.4 — fixed in 17.10.4, 17.8.6, 17.8.7, 17.9.6
How to fix
Upgrade to a fixed version: GitLab 17.10.4, 17.8.6, 17.8.7, 17.9.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11129 or the next vulnerability affects your stack