What’s Vulnerable › Vulnerabilities
CVE-2024-11148: OpenBSD httpd(8) null dereference
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-05 · updated 2026-06-17
- Weakness: CWE-476
Description
In OpenBSD 7.4 before errata 006 and OpenBSD 7.3 before errata 020, httpd(8) is vulnerable to a NULL dereference when handling a malformed fastcgi request.
Affected products
- OpenBSD: before 7.3; 7.3, 7.3-errata_001, 7.3-errata_002, 7.3-errata_003, 7.3-errata_004, 7.3-errata_005 (+20) — fixed in 7.3
How to fix
Upgrade to a fixed version: OpenBSD 7.3. Check the vendor advisory for mitigations.
References
- https://ftp.openbsd.org/pub/OpenBSD/patches/7.3/common/020_httpd.patch.sig
- https://ftp.openbsd.org/pub/OpenBSD/patches/7.4/common/006_httpd.patch.sig
Get alerted when CVE-2024-11148 or the next vulnerability affects your stack