What’s Vulnerable › Vulnerabilities
CVE-2024-11150: WordPress User Extra Fields <= 16.6 - Unauthenticated Arbitrary File Deletion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-22
Description
The WordPress User Extra Fields plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the delete_tmp_uploaded_file() function in all versions up to, and including, 16.6. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
Affected products
- vanquish WordPress User Extra Fields: before 16.7 — fixed in 16.7
How to fix
Upgrade to a fixed version: vanquish WordPress User Extra Fields 16.7. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/user-extra-fields/12949844
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ad39d797-9230-41d9-a335-864845b56aa0?source=cve
Get alerted when CVE-2024-11150 or the next vulnerability affects your stack