What’s Vulnerable › Vulnerabilities
CVE-2024-11165
- Severity: medium (CVSS 5.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-532
Description
An information disclosure vulnerability exists in the backup configuration process where the SAS token is not masked in the configuration response. This oversight results in sensitive information leakage within the yb_backup log files, exposing the SAS token in plaintext. The leakage occurs during the backup procedure, leading to potential unauthorized access to resources associated with the SAS token. This issue affects YugabyteDB Anywhere: from 2.20.0.0 before 2.20.7.0, from 2.23.0.0 before 2.23.1.0, from 2024.1.0.0 before 2024.1.3.0.
Affected products
- YugabyteDB Anywhere: from 2.20.0.0 before 2.20.7.0; from 2.23.0.0 before 2.23.1.0; from 2024.1.0.0 before 2024.1.3.0 — fixed in 2.20.7.0, 2.23.1.0, 2024.1.3.0
How to fix
Upgrade to a fixed version: YugabyteDB Anywhere 2.20.7.0, 2.23.1.0, 2024.1.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11165 or the next vulnerability affects your stack