What’s Vulnerable › Vulnerabilities
CVE-2024-11170: Path Traversal in danny-avila/librechat
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-29
Description
A vulnerability in danny-avila/librechat version git 81f2936 allows for path traversal due to improper sanitization of file paths by the multer middleware. This can lead to arbitrary file write and potentially remote code execution. The issue is fixed in version 0.7.6.
Affected products
- danny-avila LibreChat: before 0.7.6 — fixed in 0.7.6
How to fix
Upgrade to a fixed version: danny-avila LibreChat 0.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/danny-avila/librechat/commit/629be5c0ca2b332178524b4e3f6fac715aea8cc4
- https://huntr.com/bounties/b64156c2-5380-4d4d-af30-b2938dcdd46e
Get alerted when CVE-2024-11170 or the next vulnerability affects your stack