What’s Vulnerable › Vulnerabilities
CVE-2024-11171: Improper Input Validation in danny-avila/librechat
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-770
Description
In danny-avila/librechat version git 0c2a583, there is an improper input validation vulnerability. The application uses multer middleware for handling multipart file uploads. When using in-memory storage (the default setting for multer), there is no limit on the upload file size. This can lead to a server crash due to out-of-memory errors when handling large files. An attacker without any privileges can exploit this vulnerability to cause a complete denial of service. The issue is fixed in version 0.7.6.
Affected products
- danny-avila LibreChat: before 0.7.6 — fixed in 0.7.6
How to fix
Upgrade to a fixed version: danny-avila LibreChat 0.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/danny-avila/librechat/commit/bb58a2d0662ef86dc75a9d2f6560125c018e3836
- https://huntr.com/bounties/91717a5a-d653-4e35-b186-9e8d00aa4285
Get alerted when CVE-2024-11171 or the next vulnerability affects your stack