What’s Vulnerable › Vulnerabilities
CVE-2024-11189: Social Share And Social Locker – ARSocial < 1.4.2 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Share And Social Locker WordPress plugin before 1.4.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- reputeinfosystems Social Share And Social Locker: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: reputeinfosystems Social Share And Social Locker 1.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f3d1473a-6d25-447d-af27-f315323fdd62/
- https://wpscan.com/vulnerability/f3d1473a-6d25-447d-af27-f315323fdd62/
Get alerted when CVE-2024-11189 or the next vulnerability affects your stack