What’s Vulnerable › Vulnerabilities
CVE-2024-11195: Email Subscription Popup <= 1.2.22 - Authenticated (Contributor+) Stored Cross-Site Scripting via print_email_subscribe_form Shortcode
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Email Subscription Popup plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's print_email_subscribe_form shortcode in all versions up to, and including, 1.2.22 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- nik00726 Email Subscription Popup: before 1.2.23 — fixed in 1.2.23
How to fix
Upgrade to a fixed version: nik00726 Email Subscription Popup 1.2.23. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/email-subscribe/tags/1.2.22/wp-email-subscription.php#L2860
- https://plugins.trac.wordpress.org/changeset/3189989/
- https://wordpress.org/plugins/email-subscribe/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f8c18b0d-15fe-45d6-9915-85d38803c117?source=cve
Get alerted when CVE-2024-11195 or the next vulnerability affects your stack