What’s Vulnerable › Vulnerabilities
CVE-2024-11233: Single byte overread with convert.quoted-printable-decode filter
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-24 · updated 2026-06-17
- Weakness: CWE-122
Description
In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, due to an error in convert.quoted-printable-decode filter certain data can lead to buffer overread by one byte, which can in certain circumstances lead to crashes or disclose content of other memory areas.
Affected products
- PHP: from 8.1.0 before 8.1.31; from 8.2.0 before 8.2.26; from 8.3.0 before 8.3.14 — fixed in 8.1.31, 8.2.26, 8.3.14
How to fix
Upgrade to a fixed version: PHP 8.1.31, 8.2.26, 8.3.14. Check the vendor advisory for mitigations.
References
- https://github.com/php/php-src/security/advisories/GHSA-r977-prxv-hc43
- https://lists.debian.org/debian-lts-announce/2024/12/msg00007.html
- https://security.netapp.com/advisory/ntap-20241220-0008/
Get alerted when CVE-2024-11233 or the next vulnerability affects your stack