What’s Vulnerable › Vulnerabilities

CVE-2024-11234: Configuring a proxy in a stream context might allow for CRLF injection in URIs

Description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, when using streams with configured proxy and "request_fulluri" option, the URI is not properly sanitized which can lead to HTTP request smuggling and allow the attacker to use the proxy to perform arbitrary HTTP requests originating from the server, thus potentially gaining access to resources not normally available to the external user.

Affected products

How to fix

Upgrade to a fixed version: PHP 8.1.31, 8.2.26, 8.3.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-11234 or the next vulnerability affects your stack