What’s Vulnerable › Vulnerabilities
CVE-2024-11254: AMP for WP – Accelerated Mobile Pages <= 1.1.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The AMP for WP – Accelerated Mobile Pages plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the disqus_name parameter in all versions up to, and including, 1.1.1 due to insufficient input validation. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- mohammed_kaludi AMP for WP – Accelerated Mobile Pages: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: mohammed_kaludi AMP for WP – Accelerated Mobile Pages 1.1.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/accelerated-mobile-pages/tags/1.0.93/includes/disqus.html?rev=3024147#L34
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5da82149-c827-4574-8269-b2b798edca59?source=cve
Get alerted when CVE-2024-11254 or the next vulnerability affects your stack