What’s Vulnerable › Vulnerabilities
CVE-2024-11272: Contact Form & SMTP Plugin for WordPress by PirateForms < 2.6.0 - Admin+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form & SMTP Plugin for WordPress by PirateForms WordPress plugin before 2.6.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- WPForms Pirate Forms: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: WPForms Pirate Forms 2.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11272 or the next vulnerability affects your stack