What’s Vulnerable › Vulnerabilities
CVE-2024-11282: Passster – Password Protect Pages and Content <= 4.2.10 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-200
Description
The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.10 via the WordPress core search feature. This makes it possible for unauthenticated attackers to extract sensitive data from posts that have been restricted to higher-level roles such as administrator.
Affected products
- wpchill Passster – Password Protect Pages and Content: before 4.2.11 — fixed in 4.2.11
How to fix
Upgrade to a fixed version: wpchill Passster – Password Protect Pages and Content 4.2.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3211004/content-protector
- https://www.wordfence.com/threat-intel/vulnerabilities/id/11782a65-30b9-400e-8fe0-ab9f05ba5e42?source=cve
Get alerted when CVE-2024-11282 or the next vulnerability affects your stack