What’s Vulnerable › Vulnerabilities
CVE-2024-11297: Page Restriction WordPress (WP) – Protect WP Pages/Post <= 1.3.6 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-20 · updated 2026-06-17
- Weakness: CWE-200
Description
The Page Restriction WordPress (WP) – Protect WP Pages/Post plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.3.6 via the WordPress core search feature. This makes it possible for unauthenticated attackers to extract sensitive data from posts that have been restricted to higher-level roles such as administrator.
Affected products
- cyberlord92 Page and Post Restriction: before 1.3.7 — fixed in 1.3.7
How to fix
Upgrade to a fixed version: cyberlord92 Page and Post Restriction 1.3.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3212690%40page-and-post-restriction&new=3212690%40page-and-post-restriction&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/page-and-post-restriction/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d12ab8c-d5d0-4e02-986e-e894fae073e5?source=cve
Get alerted when CVE-2024-11297 or the next vulnerability affects your stack