What’s Vulnerable › Vulnerabilities
CVE-2024-11300: Improper Access Control in lunary-ai/lunary
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-639
Description
In lunary-ai/lunary before version 1.6.3, an improper access control vulnerability exists where a user can access prompt data of another user. This issue affects version 1.6.2 and the main branch. The vulnerability allows unauthorized users to view sensitive prompt data by accessing specific URLs, leading to potential exposure of critical information.
Affected products
- lunary-ai/lunary: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/79dc370596d979b756f6ea0250d97a2d02385ecd
- https://huntr.com/bounties/8dca7994-0d92-491e-a419-02adfe23ffa4
- https://huntr.com/bounties/8dca7994-0d92-491e-a419-02adfe23ffa4
Get alerted when CVE-2024-11300 or the next vulnerability affects your stack