What’s Vulnerable › Vulnerabilities
CVE-2024-11301: Improper Enforcement of Unique Constraint in lunary-ai/lunary
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-837
Description
In lunary-ai/lunary before version 1.6.3, the application allows the creation of evaluators without enforcing a unique constraint on the combination of projectId and slug. This allows an attacker to overwrite existing data by submitting a POST request with the same slug as an existing evaluator. The lack of database constraints or application-layer validation to prevent duplicates exposes the application to data integrity issues. This vulnerability can result in corrupted data and potentially malicious actions, impairing the system's functionality.
Affected products
- lunary-ai/lunary: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/79dc370596d979b756f6ea0250d97a2d02385ecd
- https://huntr.com/bounties/3d99aca5-b135-4833-b48b-7806bc4bf861
Get alerted when CVE-2024-11301 or the next vulnerability affects your stack