What’s Vulnerable › Vulnerabilities
CVE-2024-11350: AdForest <= 5.1.6 - Privilege Escalation via Password Reset/Account Takeover
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-640
Description
The AdForest theme for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 5.1.6. This is due to the plugin not properly validating a user's identity prior to updating their password through the adforest_reset_password() function. This makes it possible for unauthenticated attackers to change arbitrary user's passwords, including administrators, and leverage that to gain access to their account.
Affected products
- scriptsbundle AdForest: before 5.1.7 — fixed in 5.1.7
How to fix
Upgrade to a fixed version: scriptsbundle AdForest 5.1.7. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/adforest-classified-wordpress-theme/19481695
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4ebb766a-44e9-460c-be84-356b7403e593?source=cve
Get alerted when CVE-2024-11350 or the next vulnerability affects your stack