What’s Vulnerable › Vulnerabilities
CVE-2024-11357: Goodlayers Core < 2.0.10 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The goodlayers-core WordPress plugin before 2.0.10 does not sanitise and escape some of its settings, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- goodlayers-core: before 2.0.10 — fixed in 2.0.10
How to fix
Upgrade to a fixed version: goodlayers-core 2.0.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7e8c6816-9b7a-43e8-9508-789c8051dd9b/
- https://wpscan.com/vulnerability/7e8c6816-9b7a-43e8-9508-789c8051dd9b/
Get alerted when CVE-2024-11357 or the next vulnerability affects your stack