What’s Vulnerable › Vulnerabilities
CVE-2024-11420: Blocksy <= 2.0.77 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Blocksy theme for WordPress is vulnerable to Stored Cross-Site Scripting via the Contact Info Block link parameter in all versions up to, and including, 2.0.77 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- creativethemeshq Blocksy: before 2.0.78 — fixed in 2.0.78
How to fix
Upgrade to a fixed version: creativethemeshq Blocksy 2.0.78. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/changeset/249744/blocksy/2.0.78/inc/components/contacts-box.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/02ad47d5-f011-4e0a-af29-088852d1e886?source=cve
Get alerted when CVE-2024-11420 or the next vulnerability affects your stack