What’s Vulnerable › Vulnerabilities
CVE-2024-11426: AutoListicle: Automatically Update Numbered List Articles <= 1.2.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The AutoListicle: Automatically Update Numbered List Articles plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'auto-list-number' shortcode in all versions up to, and including, 1.2.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
References
- https://plugins.trac.wordpress.org/browser/autolisticle-automatically-update-numbered-list-articles/trunk/autolisticle.php#L62
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3194263%40autolisticle-automatically-update-numbered-list-articles&new=3194263%40autolisticle-automatically-update-numbered-list-articles&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e75313c5-dbc9-4a33-898e-47d8fd299a42?source=cve
Get alerted when CVE-2024-11426 or the next vulnerability affects your stack