What’s Vulnerable › Vulnerabilities
CVE-2024-11453: WordPress Pinterest Plugin – Make a Popup, User Profile, Masonry and Gallery Layout <= 1.8.8 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The WordPress Pinterest Plugin – Make a Popup, User Profile, Masonry and Gallery Layout plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'gs_pin_widget' shortcode in all versions up to, and including, 1.8.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- GS Plugins GS Pins for Pinterest: before 1.8.9 — fixed in 1.8.9
How to fix
Upgrade to a fixed version: GS Plugins GS Pins for Pinterest 1.8.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/gs-pinterest-portfolio/tags/1.8.8/includes/shortcode.php#L202
- https://plugins.trac.wordpress.org/changeset/3200115/gs-pinterest-portfolio/trunk/includes/shortcode.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/425cd0be-d17e-4c2b-bf29-3b850905a88e?source=cve
Get alerted when CVE-2024-11453 or the next vulnerability affects your stack