What’s Vulnerable › Vulnerabilities
CVE-2024-11596: Buffer Over-read in Wireshark
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-21 · updated 2026-06-17
- Weakness: CWE-126
Description
ECMP dissector crash in Wireshark 4.4.0 to 4.4.1 and 4.2.0 to 4.2.8 allows denial of service via packet injection or crafted capture file
Affected products
- Wireshark Foundation Wireshark: from 4.2.0 before 4.2.9; from 4.4.0 before 4.4.2 — fixed in 4.2.9, 4.4.2
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 4.2.9, 4.4.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/wireshark/wireshark/-/issues/20214
- https://www.wireshark.org/security/wnpa-sec-2024-15.html
Get alerted when CVE-2024-11596 or the next vulnerability affects your stack