What’s Vulnerable › Vulnerabilities
CVE-2024-11613: WordPress File Upload <= 4.24.15 - Unauthenticated Remote Code Execution, Arbitrary File Read, and Arbitrary File Deletion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-94
Description
The WordPress File Upload plugin for WordPress is vulnerable to Remote Code Execution, Arbitrary File Read, and Arbitrary File Deletion in all versions up to, and including, 4.24.15 via the 'wfu_file_downloader.php' file. This is due to lack of proper sanitization of the 'source' parameter and allowing a user-defined directory path. This makes it possible for unauthenticated attackers to execute code on the server.
Affected products
- nickboss Iptanus File Upload: before 4.25.0 — fixed in 4.25.0
How to fix
Upgrade to a fixed version: nickboss Iptanus File Upload 4.25.0. Check the vendor advisory for mitigations.
References
- https://abrahack.com/posts/wp-file-upload-rce-part2/
- https://plugins.svn.wordpress.org/wp-file-upload/trunk/wfu_file_downloader.php
- https://plugins.trac.wordpress.org/changeset/3217005/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/31052fe6-a0ae-4502-b2d2-dbc3b3bf672f?source=cve
Get alerted when CVE-2024-11613 or the next vulnerability affects your stack