What’s Vulnerable › Vulnerabilities
CVE-2024-11634
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-77
Description
Command injection in Ivanti Connect Secure before version 22.7R2.3 and Ivanti Policy Secure before version 22.7R1.2 allows a remote authenticated attacker with admin privileges to achieve remote code execution. (Not applicable to 9.1Rx)
Affected products
- Ivanti Connect Secure (Pulse Secure): before 22.7; 22.7, 22.7-r1, 22.7-r1.1, 22.7-r1.2, 22.7-r1.3, 22.7-r1.4 (+4) — fixed in 22.7
- Ivanti Policy Secure: before 22.7; 22.7, 22.7-r1, 22.7-r1.1 — fixed in 22.7
How to fix
Upgrade to a fixed version: Ivanti Connect Secure (Pulse Secure) 22.7; Ivanti Policy Secure 22.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11634 or the next vulnerability affects your stack