What’s Vulnerable › Vulnerabilities
CVE-2024-11635: WordPress File Upload <= 4.24.12 - Unuathenticated Remote Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-94
Description
The WordPress File Upload plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.24.12 via the 'wfu_ABSPATH' cookie parameter. This makes it possible for unauthenticated attackers to execute code on the server.
Affected products
- nickboss Iptanus File Upload: before 4.24.15 — fixed in 4.24.15
How to fix
Upgrade to a fixed version: nickboss Iptanus File Upload 4.24.15. Check the vendor advisory for mitigations.
References
- https://abrahack.com/posts/wp-file-upload-rce-part1/
- https://plugins.svn.wordpress.org/wp-file-upload/trunk/wfu_file_downloader.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b5165f60-6515-4a2c-a124-cc88155eaf01?source=cve
Get alerted when CVE-2024-11635 or the next vulnerability affects your stack