What’s Vulnerable › Vulnerabilities
CVE-2024-11640: VikRentCar Car Rental Management System <= 1.4.2 - Cross-Site Request Forgery to Authenticated (Subscriber+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-08 · updated 2026-06-17
- Weakness: CWE-352
Description
The VikRentCar Car Rental Management System plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4.2. This is due to missing or incorrect nonce validation on the 'save' function. This makes it possible for unauthenticated attackers to change plugin access privileges via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Successful exploitation allows attackers with subscriber-level privileges and above to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- e4jvikwp VikRentCar: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: e4jvikwp VikRentCar 1.4.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3225040/vikrentcar
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4a4c085a-1601-4c1a-ac17-0f2cf5d02489?source=cve
Get alerted when CVE-2024-11640 or the next vulnerability affects your stack