What’s Vulnerable › Vulnerabilities
CVE-2024-11668: Insufficient Session Expiration in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-613
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 16.11 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. Long-lived connections could potentially bypass authentication controls, allowing unauthorized access to streaming results.
Affected products
- GitLab: from 16.11.0 before 17.4.5; from 17.5.0 before 17.5.3; 17.6.0 — fixed in 17.4.5, 17.5.3
How to fix
Upgrade to a fixed version: GitLab 17.4.5, 17.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11668 or the next vulnerability affects your stack