What’s Vulnerable › Vulnerabilities
CVE-2024-11669: Incorrect Authorization in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in GitLab CE/EE affecting all versions from 16.9.8 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. Certain API endpoints could potentially allow unauthorized access to sensitive data due to overly broad application of token scopes.
Affected products
- GitLab: from 16.9.8 before 17.4.5; from 17.5.0 before 17.5.3; 17.6.0 — fixed in 17.4.5, 17.5.3
How to fix
Upgrade to a fixed version: GitLab 17.4.5, 17.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11669 or the next vulnerability affects your stack