What’s Vulnerable › Vulnerabilities
CVE-2024-1169: Post Form – Registration Form – Profile Form for User Profiles – Frontend Content Forms for User Submissions (UGC) <= 2.8.7 - Missing Authorization to Unauthenticated Media Upload
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The Post Form – Registration Form – Profile Form for User Profiles – Frontend Content Forms for User Submissions (UGC) plugin for WordPress is vulnerable to unauthorized media upload due to a missing capability check on the buddyforms_upload_handle_dropped_media function in all versions up to, and including, 2.8.7. This makes it possible for unauthenticated attackers to upload media files.
Affected products
- themekraft Post Form – Registration Form – Profile Form for User Profiles – Frontend Content Forms for User Submissions : before 2.8.8 — fixed in 2.8.8
How to fix
Upgrade to a fixed version: themekraft Post Form – Registration Form – Profile Form for User Profiles – Frontend Content Forms for User Submissions 2.8.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/buddyforms/trunk/includes/functions.php#L1466
- https://plugins.trac.wordpress.org/changeset/3046092/buddyforms/trunk/includes/functions.php?contextall=1&old=3023795&old_path=%2Fbuddyforms%2Ftrunk%2Fincludes%2Ffunctions.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d14a90d-65ea-45da-956b-0735e2e2b538?source=cve
- https://plugins.trac.wordpress.org/browser/buddyforms/trunk/includes/functions.php#L1466
- https://plugins.trac.wordpress.org/changeset/3046092/buddyforms/trunk/includes/functions.php?contextall=1&old=3023795&old_path=%2Fbuddyforms%2Ftrunk%2Fincludes%2Ffunctions.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d14a90d-65ea-45da-956b-0735e2e2b538?source=cve
Get alerted when CVE-2024-1169 or the next vulnerability affects your stack