What’s Vulnerable › Vulnerabilities
CVE-2024-11704
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-415
Description
A double-free issue could have occurred in `sec_pkcs7_decoder_start_decrypt()` when handling an error path. Under specific conditions, the same symmetric key could have been freed twice, potentially leading to memory corruption. This vulnerability affects Firefox < 133, Thunderbird < 133, Firefox ESR < 128.7, and Thunderbird < 128.7.
Affected products
- Mozilla Firefox: before 128.7.0; before 133.0 — fixed in 128.7.0, 133.0
- Mozilla Thunderbird: before 128.7.0; from 129.0 before 133.0 — fixed in 128.7.0, 133.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 128.7.0, 133.0; Mozilla Thunderbird 128.7.0, 133.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1899402
- https://www.mozilla.org/security/advisories/mfsa2024-63/
- https://www.mozilla.org/security/advisories/mfsa2024-67/
- https://www.mozilla.org/security/advisories/mfsa2025-09/
- https://www.mozilla.org/security/advisories/mfsa2025-10/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00005.html
- https://lists.debian.org/debian-lts-announce/2025/02/msg00006.html
Get alerted when CVE-2024-11704 or the next vulnerability affects your stack