What’s Vulnerable › Vulnerabilities
CVE-2024-11718: tarteaucitron.js for WordPress < 0.3.0 - Author+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The tarteaucitron-wp WordPress plugin before 0.3.0 allows author level and above users to add HTML into a post/page, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- tarteaucitron-wp: before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: tarteaucitron-wp 0.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/02da3a49-20e4-4476-a78d-4c627994a90a/
- https://wpscan.com/vulnerability/02da3a49-20e4-4476-a78d-4c627994a90a/
Get alerted when CVE-2024-11718 or the next vulnerability affects your stack