What’s Vulnerable › Vulnerabilities
CVE-2024-11721: Frontend Admin by DynamiApps <= 3.24.5 - Unauthenticated Privilege Escalation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-14 · updated 2026-06-17
- Weakness: CWE-269
Description
The Frontend Admin by DynamiApps plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 3.24.5. This is due to insufficient controls on the user role select field when utilizing the 'Role' field in a form. This makes it possible for unauthenticated attackers to create new administrative user accounts, even when the administrative user role has not been provided as an option to the user, granted that unauthenticated users have been provided access to the form.
Affected products
- shabti Frontend Admin by DynamiApps: before 3.25.1 — fixed in 3.25.1
How to fix
Upgrade to a fixed version: shabti Frontend Admin by DynamiApps 3.25.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3204192/acf-frontend-form-element/trunk/main/frontend/fields/user/class-role.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e9fdc833-8384-42c0-ad9b-72e5b6351964?source=cve
Get alerted when CVE-2024-11721 or the next vulnerability affects your stack