What’s Vulnerable › Vulnerabilities
CVE-2024-11730: KiviCare – Clinic & Patient Management System (EHR) <= 3.6.4 - Authenticated (Doctor/Receptionist+) SQL Injection
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-06 · updated 2026-06-17
- Weakness: CWE-89
Description
The KiviCare – Clinic & Patient Management System (EHR) plugin for WordPress is vulnerable to SQL Injection via the 'sort[]' parameter of the static_data_list AJAX action in all versions up to, and including, 3.6.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with doctor/receptionist-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- iqonicdesign KiviCare – Clinic & Patient Management System (EHR): before 3.6.5 — fixed in 3.6.5
How to fix
Upgrade to a fixed version: iqonicdesign KiviCare – Clinic & Patient Management System (EHR) 3.6.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3201428/kivicare-clinic-management-system/trunk/app/controllers/KCStaticDataController.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/30f2a3ee-7f95-478c-b3d7-c254b9472d42?source=cve
Get alerted when CVE-2024-11730 or the next vulnerability affects your stack