What’s Vulnerable › Vulnerabilities
CVE-2024-11731: Master Slider – Responsive Touch Slider <= 3.10.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via ms_slider Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Master Slider – Responsive Touch Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's ms_slider shortcode in all versions up to, and including, 3.10.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This issue was partially fixed in version 3.10.8.
Affected products
- averta Master Slider – Responsive Touch Slider: before 3.10.7 — fixed in 3.10.7
How to fix
Upgrade to a fixed version: averta Master Slider – Responsive Touch Slider 3.10.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/master-slider/tags/3.10.8/includes/msp-shortcodes.php#L526
- https://plugins.trac.wordpress.org/changeset/3288436
- https://wordpress.org/plugins/master-slider/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f1dcafe1-bdba-4476-bcc7-ad844da38a01?source=cve
Get alerted when CVE-2024-11731 or the next vulnerability affects your stack