What’s Vulnerable › Vulnerabilities
CVE-2024-11740: Download Manager <= 3.3.03 - Unauthenticated Arbitrary Shortcode Execution
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-94
Description
The The Download Manager plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 3.3.03. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Affected products
- codename065 Download Manager: before 3.3.04 — fixed in 3.3.04
How to fix
Upgrade to a fixed version: codename065 Download Manager 3.3.04. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/download-manager/tags/3.3.02/src/Package/Hooks.php#L42
- https://plugins.trac.wordpress.org/browser/download-manager/tags/3.3.02/src/Package/views/shortcode-iframe.php#L203
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4a7be578-5883-4cd3-963d-bf81c3af2003?source=cve
Get alerted when CVE-2024-11740 or the next vulnerability affects your stack