What’s Vulnerable › Vulnerabilities
CVE-2024-11746: Discover the Best Woocommerce Product Brands Plugin for WordPress – Woocommerce Brands Plugin <= 1.3.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Discover the Best Woocommerce Product Brands Plugin for WordPress – Woocommerce Brands Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'product_brand' shortcode in all versions up to, and including, 1.3.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- samdani GS Brands for WooCommerce: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: samdani GS Brands for WooCommerce 1.3.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/gs-woo-brands/tags/1.3.1/woocommerce-brand.php#L299
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3235325%40gs-woo-brands&new=3235325%40gs-woo-brands&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/443cfb7b-4566-4a71-ac31-5a5361c58aa2?source=cve
Get alerted when CVE-2024-11746 or the next vulnerability affects your stack